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Two Required Textbooks 

 



3D animation tool in IAT 343 

• Autodesk Maya 3D 2011 version at SFU Surrey campus, not 
2012 version. If you use 2012 version at home, the school 
computer with 2011 version may not able to handle/open 
2012 version.   

• All your team members should use the same version. 

• Free Autodesk software for students 
(http://students.autodesk.com/?nd=download_center ) 

http://usa.autodesk.com/maya/ 

 

http://students.autodesk.com/?nd=download_center
http://students.autodesk.com/?nd=download_center
http://usa.autodesk.com/maya/
http://usa.autodesk.com/maya/


Course overview 
1. Individual  

1. Web Portfolio (16%) 
1.  Modeling + shading + texturing 
2. Character Animation  

2. Individual  Lab exercises (11 %) 
 

3. Participation/Quiz (15%) 
1. 2 quizzes (5% each, 8%) 
2. Attendance (5%) 

 
4. Essay (2 %) 2 to 3 page – single space with images, APA reference style 

 
5. Final exam (20 %) 

 
2. Group project (35%) 

1. Script & character-environment sketch (3%) 
2. Storyboard with pitch (4%) 
3. Three second animation drawing  (2%) 

• pencil or Adobe Flash,  
• 24f/2 x 3 second = 36 frames,  
• separate character(s) and background in layers) 

4. Animatic (animated video storyboard with pitch)(4%) 
5. Animation short video (20%) 
6. Final presentation & Documentation (2%) 

 
 

 
 

 
 

 



Team Project  
(look for team members! Size 1 to 5) 

• Due dates (1/29, Sunday) 

 

1. Script 
• 1 page, could be extended with dialog 

 

2. Character & Environment Sketch with Description 

• Character history 

• Personality 

• Background 

• Shape, size etc. 

• Location 

• Atmosphere & mood etc. 

 

 

http://www.sfu.ca/~zjb/iat343/port1.html


All the course materials available through  
SFU WebCT IAT 343 

http://webct.sfu.ca/ 

Download ‘Lab01_343.zip’ file 
from the WebCT 



Today’s Lab 

1. Overview of 3D geometry & User Interface 
& Navigation in Maya 3D 

 

2. Lab exercises 

  1.1: File Import & Transformation  

  1.2: Duplication 

  1.3: Shape modification 

 

Due Dates:  

• Individual: Lab Exercises week 1 – 3 & 

individual website. (2/05) 

 

• Team: Script, team website & character 

sketch (1/29) 
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Coordinate System 
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Coordinate System 

 

• Cartesian coordinate system 

– Two axes perpendicular each 
other and met at the origin. 

– Horizontal axis: x 

– Vertical axis: y 

– 3D Cartesian system by 
extending along the Z axis 

 

 

 

 

 

 

 

 

(Hearn, 2003) 

 

Source: http://www.xvrml.net/tutorial/images/rightHandRule.png 



Polygon terminology 

• Simple Geometric Forms 

– Points (Vertex in Maya) 

– Lines (Edge in Maya) 

– Polylines 

– Polygons (Face in Maya) 

 

 

 

 

Polygons are straight-sided shapes (3 or more 
sides), defined by three-dimensional points 
(vertices) and the straight lines that connect them 
(edges). The interior region of the polygon is called 
the face. Vertices, edges, and faces are the basic 
components of polygons. You select and modify 
polygons using these basic components.  
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Point, Lines & Primitives 

struct Point  

{  

int x;  

int y;  

}  

 

struct Line  

{  

Point start;  

Point end; 

 } 

struct Polygon  

{  

 int total_points;  

 array<Point> points;  

} 

 

 

 

 

 

Source: Game Graphics Programming by Allen Sherrod 

struct Vector3D  
{  

float x, y, z;  
};  
 
struct Vector3D  
{  

float pos[3];  
}  
struct Sphere  
{  
 int radius;  
 Point position;  
} 
 

•Point: a location in space plus its color 
•Scalar: a number that we multiply other 
variables by 
•Vector: a line that has magnitude, direction 
and a color 

Source: OpenGL graphics through applications / Robert Whitrow 



Graphic User Interface of 3D Animation Software 



Interface & Navigation Comparison 

 

Which interface design do you prefer,  

Firefox or Internet Explorer? 



Differences in Interface Design across diverse 
applications 

• Web application 

– Internet Explorer, FireFox 

 

• 2D imaging application 

– Adobe Photoshop 

 

• Application Development Tool 

– Java Eclipse, Microsoft Visual Studio 

 

• 3D applications  

– Animation 

– CAD 

– Data visualization 

 



Important Elements in User Interface 

• Easy to use, learning curve 

• Workflow 

• Productivity 

• Customization 

• Layout optimization 

 

 • Can you imagine… 

• How many button clicks were 
performed to make this scene? 

 

• Was UI optimized when 
performing the render of this 
scene? 

 

• Any human error during the 
production due to UI? 

 

 

 



 

Maya 3D Interface 



To generate this scene in the most effective-efficient manner, 
could a User Interface of 3D software affect the productivity 
and quality of 3D animation? How should a User Interface of 3D 
animation system look alike? Is there any principle?  

Star Wars 



Story Board 

Modeling 

Animation 

Shading 

Lighting 

Rendering 

Animation Process 

Source:  

Pixar Animation Studio 



Integrating animation production stages into User Interface 

 



Viewing Projections in 3D Space 



• 3D projection is any method of mapping three-

dimensional points to a two-dimensional plane. As most 

current methods for displaying graphical data are based 

on planar two-dimensional media, the use of this type of 

projection is widespread, especially in computer 

graphics, engineering and drafting. 

http://en.wikipedia.org/wiki/3D_projection 

http://en.wikipedia.org/wiki/Perspective_%2

8graphical%29 



http://www.ul.ie/~rynnet/orthographic_projection_fyp/webpages/home.html 

Orthographic Projection 



Perspective Projection 



Multiple Viewport Projection  
 
 
 

Top view 

Front view 

Side view 

Perspective 
view 



Taxonomy of Projection 

Projection 

Perspective Parallel 

One  

Vanishing 

Point 

Two 

 Vanishing 

Point 

Three  

Vanishing  

Point 

Orthographic Oblique 

Multiview Axonometric 
General 

Isometric Dimetric Trimetric 

Cavarier Cabinet 

Perspective foreshortening is the illusion that objects and lengths appear smaller as their 
distance from the center of projection increases. (Source: Schaums Outline of Computer 
Graphics by Zhigang Xiang & Roy A. Plastock 



Interface in Maya 

Layout changes 

 

To switch views:  

Put the Mouse Cursor 
inside a Target 
view > tab Space 
bar 

 



Interface in Maya 

Panel Menu 

 

Panels > Perspective 

Panels > Orthographic >front, side, 
top 

 

Shading 

   Wireframe: ‘4’ 

   Flat shade: ‘5’ 

   Textured: ‘6’ 

 

 

 



2. Shortcut keys to transform objects 

q: select 

w: move 

e: rotate 

r: scale 

Insert/home – edit pivot 
 

3. Navigation 

  Switch viewport:  

  tab ‘Spacebar’ 

 Tumble/spin/rotate view: 

  ‘Alt + LMB’ 

 Track/pan/side-to-side: 

  ‘Alt + MMB’ 

 Dolly/zoom view: 

  ‘Alt + RMB’ 

 Focus on objects: ‘F’ 

 Focus on objects in all viewport windows: Shift + ‘F’ 

 Frame all: ‘A’ 

 

 

Help menu: User Guide > General > Basics > Basics Tools >   
1. Create > Polygon Primitives > Cube. (Interactive Creation mode on/off) 



To acces more information about Camera Tools, pressing ‘F1’ open up 
the Help menu.  
Learning Resources > Tutorials > Getting Started with Maya > Maya 
Basics > Lesson 3: Viewing the Maya 3D scene >  Camera tools 



If you can’t find menu bar… 
 

Display > UI Elements 



Creating new Project Directory 

 

1. Launch Autodesk Maya. 
 

2. Go to File menu > Project > New, then 
choose Location of a project (click 
‘Browse’) and give a project name (e.g. 
‘LastName_Lab01’). 
 

3. By clicking Use Defaults button, all sub-
directories are created to keep different 
digital assets. 
 

4. Press Accept button when done.  
 

5. Open the Window Explorer (Start + E) to 
review whether these directories has 
been created. 

 

 

 

 
 

Lab Exercise 1. 0 
Organization: Project set-up 



Ex 1_1. Navigation & Transformation 

Source: http://static.howstuffworks.com/gif/space-shuttle-glass-cockpit2.jpg 

Source: http://www.telecoms.com/18914/vodafone-navigation-unit-at-dead-end/ 

Source: 

http://blog.niot.net/en/post/163173/video:+mexican+chevy+dealer%27s+transforming+bumblebe

e+suit+has+us+jonesin%27+for+halloween.htm 



Ways to generate an object in Maya 3D space 

1. Scripting through MEL (Maya scripting language) 

 

2. File import 

 

3. Using pre-defined 3D primitives  



 Object Creation & Transformation  
through scripting 

• To create a cone 
– Type cone and press Enter (try with the 

numeric keypad). 
– Press ‘f’ to focus on the selected 

object. 

 

• To transform the object across x, y, & z axis. 
– rotate 0 0 90 <Enter> 

– move 5 2 5 <Enter> 

– scale 2 1 1 <Enter>  

 

 

 
 
 

 
 

 



1. Download ‘Lab01_IAT343f10.zip’ file from the WebCT and import 
‘agent343f10.obj’ into Maya (File > Import). To focus the current 
camera view  on this object, click on this model and press ‘F’ on the 
keyboard. 
 

2. To navigate this view, press/hold ‘Alt’ button and click-move with 
either the left, middle or right button of your mouse.  Camera 
navigation can be accessed through View > Camera Tools on each 
viewport. 
 

3. By pressing ‘5’ (or 4), we can switch the surface shading of 3D model 
from ‘Wireframe (4)’ to ‘Smooth (5)’. This function can also be access 
by selecting ‘Shading’ inside the viewport.  
 

4. Using Transformation tools (Move:’W’, Rotate:’E’ or Scale:’R’), we can 
reposition the current location of the object and orient along with 
different axis (x:red arrow, y:green arrow or z:blue arrow). In addition, 
apply scaling across different axis. 
 

5. To ‘undo’ previous steps, simply press ‘z’ multiple times (or apply Edit 
> Undo’).  
 

6. Import ‘cube.obj’ and place the character on top of the cube based on 
previous steps. Save your file (File > Save Scene As >  
‘LastName_1_1.mb’) for the assignment submission. Feel free to 
modify this exercise. 
 

7. By pressing ‘Del’ (or ‘Backspace’) key, we can remove a selected 
object.   
 

8. Feel free to import more than one file. 
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Ex 1.1.  File Import, Navigation & 
Transformation 

Link to ‘obj’ file 
format(http://people.sc.fsu.edu/~jb
urkardt/data/mtl/mtl.html ) 

http://people.sc.fsu.edu/~jburkardt/data/mtl/mtl.html
http://people.sc.fsu.edu/~jburkardt/data/mtl/mtl.html
http://people.sc.fsu.edu/~jburkardt/data/mtl/mtl.html


9. Let’s import another file ‘Female_parts.mb’.  
 

10. If a certain view doesn’t show this object, press ‘A’ to zoom all.   
There are different ways to locate a target object and one 
approach is to use ‘Outliner’ scene management window (. 
 

11. To move different parts of female body as a group, select all 
the parts inside outliner by click-drag (or just mouse drag while 
holding left mouse button) and press Ctrl + G to group  into one 
object.  To rename the default name, just  double-click on the 
label  ‘group1’ and retype  (i.e., FemaleFullBody) 
 

12. When we select the Move tool, Maya shows the pivot point 
(center point) of the grouped object which shown at the origin. 
To reposition the pivot point into the approximated center 
region of the multi[le-parts, we need to apply a function 
(Modify > Center Pivot).  Reposition the female body near the 
cube. 
 

13. Feel free to transform any object. 
 

14. Re-save this file  for the lab submission  
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Grouping 



Ex 1.2. Model Duplication 

 

Lord of the Rings 

The Mummy 



1. Using the Selection tool (or press ‘q’), select a target object for 
duplication. By pressing Ctrl + D, we can duplicate an object on 
top of the original object. To verify this, open the Outliner which 
shows all the objects in the scene (go to Window > Outliner). 
Using the Move tool (‘W’), reposition the duplicated object.  
 

2. To generate multiple copies, Go to Edit > Duplicate Special 
Option Box. Select Help > Help on Duplicate Special Options. 
 

3. Apply values in different parameters (e.g., Number of copies, 
Rotate, Translate).  Each box next to Translate, Rotate and Scale 
indicates X, Y and Z values. Click Apply. You can select multiple 
objects, not just single, and apply the duplication. To group 
certain objects, apply Edit > Group (or Ctrl + G) and rename it 
(e.g. ‘agent343Clan’). Save your scene as ‘LastName_1_2.mb’.  
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Ex 1.2. Duplication 



Important! 

• Back up your files (USB or portable hard drive) 

 

• Do not run your Maya file (*.mb) directly from USB. 

 

• Always create a new project folder directory including all the 
default sub-folders.  So, Maya 3D can search for the right 
location of your Maya files (under scenes sub-directory) and 
other scene assets. 



Auto-save instruction 

To save your scene automatically in timed intervals  
1. Select Window > Settings/Preferences > 

Preferences. The Preferences window appears.  
2. In the Categories, under the Settings section, 

select Files/Projects.  
3. In the Autosave section, turn on Enable.  
4. Set any additional options and click the Save 

button.  

User Guide > General > Basics > File management >   

Autosave a file 


