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Class Resources 

• Maya documentation:  
– Access through Maya application: Help > Learning 

Resources > Tutorials >   

 Or go to 
 http://download.autodesk.com/us/maya/2011help/index.html 

 

– Online including tutorial files  
 ( http://usa.autodesk.com/adsk/servlet/index?id=9502844&siteID=123112&linkID=9242256 ) 

 

Theory & Training 

http://download.autodesk.com/us/maya/2011help/index.html
http://download.autodesk.com/us/maya/2011help/index.html
http://download.autodesk.com/us/maya/2011help/index.html
http://usa.autodesk.com/adsk/servlet/index?id=9502844&siteID=123112&linkID=9242256
http://usa.autodesk.com/adsk/servlet/index?id=9502844&siteID=123112&linkID=9242256
http://usa.autodesk.com/adsk/servlet/index?id=9502844&siteID=123112&linkID=9242256


Ex 1.3. Shape Manipulation 

Portrait of Socrates 

: http://students.ou.edu/T/Mitchel.L.Tucker-1/episode_1.html 

Portrait of Bruce  Lee 

http://www.blackfitnessblog.com/wp-content/uploads/2009/03/800px-

hong_kong_bruce_lee_statue.jpg 



Polygon terminology 

• Simple Geometric Forms 

– Points (Vertex in Maya) 

– Lines (Edge in Maya) 

– Polylines 

– Polygons (Face in Maya) 

 

 

 

 

Polygons are straight-sided shapes (3 or more sides), 
defined by three-dimensional points (vertices) and the 
straight lines that connect them (edges). The interior 
region of the polygon is called the face. Vertices, edges, 
and faces are the basic components of polygons. You 
select and modify polygons using these basic 
components.  



Moving vertex 
(F9) 

Moving edge  
(F10) 

Moving face  
(F11) 

(F8) toggle object/component mode 



Help documentation about 
Edit Mesh > Cut Faces Tool 

User Guide > Modeling > Polygonal 
Modeling > Polygons menus > Edit Mesh >   
Edit Mesh > Cut Faces Tool 



1. Create new scene (File > New Scene). 
 

2. Import file: LastName1_1.mb.  
 

3. Switch to the Four View mode. To zoom all across the four 
view, press Shift + A. 
 

4. Using the Cut Faces Tool (Edit Mesh > Cut Faces Tool),  apply 
slicing between neck and body.  

5. Press/hold the right mouse button, and select Face. Through 
the mouse drag, select the all the faces under the neck. Press 
‘Delete’ button. To move the agent’s face as a group, switch 
back to  the Object mode by selecting the Object (press/hold 
the right mouse button). 
 

6. When we activate the Move tool, the center point shows the 
original position on the foot rather than the center of the face. 
To bring its pivot to the center, apply Modify > Center Pivot. 
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Ex 1.  Shape Modification 



7. Using the navigation tool (Alt + hold/move mouse button 
or View > Camera Tools) and single view (move the 
mouse cursor on a target view and press Spacebar), 
arrange the objects  on the center of the viewport. 
 

8. To manipulate vertex component(s) of the object, 
press/hold RMB and select the Vertex. Use the 
transformation tool, move vertices to change the current 
shape to more interesting look. 
 

9. A face can be extruded through Edit Mesh > Extrude. 
Whether turning on/off Keep Faces Together option, it 
will show different results. 
 

10. Save the scene as LastName1_3.mb file. 
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Lab Submission (individual assignments) 

• Due date (2/05) 

– All the lab exercises between week 1 and 3. 

– Design a simple website (no need to use Adobe Flash). 

– Upload rendered images and all the files (e.g., Maya file (mb), texture) on your 

website. 

After selecting the Render the Current Frame button, go to the File > Save Image. Select the type: ‘jpeg’.  



Selection options 
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1. Surface modeling 
• Lofting (profile curve & path) 

 
2. Polygon modeling 

 
 

3. Constructive Solid Geometry (CSG) 
• Boolean algebra 

 
4. Physically-based modeling 

• Mass-Spring Model (e.g. cloth) 
 

5. Volume visualization 
 

6. Procedural modeling 
• Particle system 
• Fractal system 
 

 
 
 
 
 

 

3D Modeling Methods/techniques 

•Solid object 
 

•Non-solid object  



12 

1. Surface modeling method 
• Lofting (profile curve & path) 



Curve-based Surface Modeling 

• Curves 

– CV (control vertices) 

• CVs (control vertices) control how 
the curve is “pulled” from a 
straight line between edit points. 
(1: box, 2.’U’ and the rest: dot) 

– EP (edit points) 

• Connection points (small ‘x’ in Maya) 

– Hulls 

• Lines between CVs 

– Isoparms 

• Lines along the surface 

– Patches 

• Enclosed area by four adjacent isoparms 

 

 

 

 

 



Surface Modeling 

Surface > Planar 

 

 

 

 

 

 

 

Surfaces > Bevel  

Creating an extruded surface with a beveled 
edge from any curve, including text curves and 
trim edges.  

Creating a planar (flat) surface within a 
boundary curve.  

• Surface > Extrude 

 

 

 

 

 

 



Modeling 

• Surface > Birail 

 

 

 

 

 

 

 

• Surface > Boundary 

 

 

 

 

 

 

• Surface > Revolve 

 

 

 

 

 

 

• Surface > Bevel 

 

 

 

 

 

 



Surface Modeling 

Surface > Planar 

 

 

 

 

 

 

 

Surface > Loft 

 

 

 

 

 

 Surface > Extrude 

 

 

 

 

 

 

Surface > Birail 

 

 

 

 

 

 

 

Surface > Boundary 

 

 

 

 

 

 

Surface > Revolve 

 

 

 

 

 

 

Surface > Bevel 

 

 

 

 

 

 



•http://www.amazon.com/Childrens-Cooking-Kits-Cookie-Cutters/dp/B000TGQOLE 
•http://www.thegreenhead.com/imgs/abc-cookie-cutters-3.jpg 

Image source: 
•http://fantes.com/images/8205cookie_cutters.jpg 

•http://www.geekalerts.com/tag/cookies/ 

Lab Exercise 2: Cookie Cutter 



Lab Exercise 2: Cookie Cutter  
Outline curves, Planar & Bevel 
 

1. First, switch to Surfaces main menu. Using the Top 
orthographic view, draw a circle: Create > NURBS Primitives > 
Circle. By holding ‘x’, we can snap on the grid. 
 

2. On the right side of UI, click on the label under INPUTS > 
makeNurbCircle1 on the Channel Box and change some 
parameter values (e.g., radius, sweep etc). If the Channel Box 
is not shown, click on the Show or hide the Channel Box / 
Layer Editor.. Add more circles and place them inside the first 
one.  
 

3. To change the number of points on the circle, change Sections 
value under the makeNurbCircle1 under INPUTS. To see the 
change, switch to the component mode (press ‘F8’ switch 
between the object and component)  
 

4. To manipulate the shape of the circle (through the circle’s 
components: points), RMB click on the circle and select the 
Edit Point. After selecting multiple points while holding the 
Shift button, use the transformation tools (Move, Scale or 
Rotate) to change the shape.  
 

5. Instead of using simple circle tool, add/draw a number of 
shapes (i.e., heart, star) through the curve tool (Create > EP 
Curve tool).  Select the new shape and make it sure the shape 
having a closed space (Edit Curves > Open/Close Curves under 
Surfaces Module).  
 

6. Use the transformation tool to refine the shape. Pressing 
‘Delete’ reduce point(s), but also slight changes on the overall 
shape. Check the center point whether repositioning of the 
pivot point is necessary (Modify > Center Pivot) 
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Surfaces main menu 

Create > NURBS Primitives > Circle 



7. Switch to the perspective view (bring the mouse cursor in 
the target view, hit the spacebar to maximize the viewport).  
 

8. To extrude a surface from the curve, select the curve(s) and 
apply Surface > Bevel. Open an Attribute Editor (Ctrl + A) . 
Click on the bevel1 tab and adjust some parameter values 
(i.e., Width, Depth). 
 

9. To see the list of the objects, go to Windows > Outliner. We 
can rename by click/type on the current text.  
 

10. To create a flat surface from curve(s), select the curve(s) and 
apply Surface > Planar.  Compare different results whether 
selecting single or multiple curves. 
 

11. Using the Outliner, select the newly created surface (i.e., 
planarTrimmedSurface2) and adjust its position. 
 

12. We can reuse the curves to generate another 3D surface. 
 

13. Save your file. 
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Could we build a guitar based on previous 
exercise? 

Source: 

http://en.wikipedia.org/wiki/File:Guitar_1.jpg 



Week 1 (1/10)  
Introduction to Animation & Modeling  
Reading:  

 Kerlow: Ch 2 (p49 – 90) &  
 
Ch 3 (93 – 114),  

 Xiang ch 1(p1-5) & ch4 (p68—77)  
  
Week 2 (1/17)  
Modeling II & Scene Composition  
Reading:  

 Kerlow: Ch 4 (p115 – 138)  
 Xiang: ch6 (p114-118), ch 7 (128-133) & 

ch 9 (p174-178)  
  

To improve your modeling skills, read these 
chapters (review the syllabus) 



Source: Wedding-Favours.ca 

Source: Starbuckcoffee.net 

Source: ikea.com 

Lab Exercise 3: Curves & Surface Modeling  

http://www.mydreamwedding.ca/search/irish+traditions


Ex 3. Curves & Surface Modeling (Beer Mug) 

Step 1: Display a reference image 
 
1. Create a new project (File > New Project) and 

generate subfolders  through pressing the Use 
Default button. Save your file first (File > Save Scene 
As , select the Maya binary). Open a web browser 
and find a reference image (i.e. glass) ,or download 
the image, ‘beer_mug.jpg’, from the Week 2 folder. 
Save it under the sourceimages sub-folder. 
 

2. To display the image in the Front view window, 
apply View > Image Plane >Import Image function in 
the Front view menu. Select the saved image.  
 

3. To adjust the position of the reference image in the 
virtual space, open an attribute editor of the 
currently selected object (Open it through either 
accessing Display > UI Elements > Attribute Editor, 
or go to the View > Image Plane >Image Plane 
Attributes > select imagePlane1 in any viewport 
menu. 
 

4. Adjust the position of the image by changing 
parameter values (x, y or z coordinates: e.g., 0.000, 
11.000, -10.000) of the Center in the Placement 
Extras section.  
 

5. Making the reference image semi-transparent 
(Alpha Gain value), it makes easier to build 3D 
geometry.  
 
 
 
 
 

http://www.mydreamwedding.ca/search/irish+traditions


Step 2: Create an outline curve and construct a surface 
 

6. To draw an outline curve of the beer bug, switch to 
‘Surfaces’ module (press F4 key). 
 

7. Before generating points for the outline curve, review the 
curve tool options through Create > EP Curve Tool > Option 
Box. Instead activating the straight curve (1 Linear), select 
the Curve Degree as 3 cubic for the smooth curve. 
 

8. Using an orthographic view (front), draw a curve which 
shapes the outline of the half of the cup. To snap a point to 
the grid cell, press and hold ‘x’ key while drawing.  
 

9. To refine the shape of the surface, click and hold RMB (right-
mouse button) and select either Edit Point or Control 
Vertex. Using the Move Tool, reposition an individual vertex 
to reshape. By pressing ‘Delete’ key, erase an unnecessary 
vertex. Also, press ‘z’ for undo. 
 

10. To add points, press and hold right-mouse button and drag 
the mouse cursor on the Edit Point mode. Under Surfaces 
module, Edit Curves > Insert Knot > Option Box. Select 
Between selections. Select two points from the curve, then 
press the Apply button. Another approach is  using the Add 
Points Tool. 
 

11. Switch back to the Object Mode by pressing F8.  Before 
generating a 3D surface from the curve, adjust a default 
option in the Surface > Revolve > Option Box.  To revolve on 
the Y-axis, select ‘Y’ in Axis preset. Click Apply. 
 

12. To change the shading of the model, press either 5(flat 
shading) or 4 (wireframe). 
 
 
 
 



Soft selection 

 



Step 3: Create a mug handle 
 

13. By pressing the spacebar, maximize the perspective 
viewport. To add a mug handle, we will add more 
divisions on the surface. Hold RMB and select Isoparm. 
By using Select Tool, click an existing isoparm line 
(change to a red line) and hold/drag the isoparm line to 
the location where you will add a new line (change to 
yellow line). Release the mouse cursor.  
 

14. Select the Edit NURBS > Insert Isoparm. To add more 
lines, repeat previous step until the surface has enough 
segments. To change the shading of the model, press 
either 4 (wireframe) or 5(flat shading). 
 

15. To create a handle for the beer mug, we will add a circle 
on top of the surface being used as the base profile 
curve.  Switch to the Object Mode and apply Modify > 
Make Live function from the top menu bar which 
converts the selected surface to a live surface. 
 

16. Switch to the side view and zoon into the handle area. 
Draw a circle by Create > NURBS Primitives > Circle on 
the cross point between lines. While having the Make 
Live mode, a curve can be drawn on top of the surface.  
Different snapping options provides more control to 
adjust the position of the curve.  
 

17. To bring the surface status back to the default state, 
apply Modify > Not Live.  Reposition the circle where  it 
matches the start of the handle in front view. 
 
 
 
 
 



 

18. Switch to the Front view. We will draw a curve 
which will be used as an outline of the handle.  

 

19. Select the Create > EP Curve Tool. Draw an 
outline of the handle close to the center 
location of the curve.  

 

20. To generate a 3D surface, select both the Circle 
and the curve through holding Shift key. Select 
the Surface > Extrude > Option Box. Set option 
parameters similar to the image on the left 
(turn on the following options: Tube, At Path, 
Path Direction). Press ‘Apply’ button.  

 

21. Open an Outliner (Window > Outliner) to see 
all the objects in the scene. 

 

22. To group two surfaces, select both objects and 
go to Edit > Group. Change the default name 
(group1) to on your own (i.e., BeerMug) 

 

23. To manipulate the 3D shape, select the Edit 
Point of the outline curve. Grab number of 
points and use Move, Rotate or Scale tool to 
deform the shape. 

 

 

 

 

 

 

 

 

 



Step 4: Save & Render 

 

24. If you haven’t saved your file, save it 

by File > Save Scene as. Choose 

mayBinary format. 

 

25. To render an image in the perspective 

view, click your mouse cursor in the 

perspective viewport  to activate. 

 

26. Press ‘Render Current Frame’ icon 

on the toolbar to bring up the Render 

View. To save an image, go to the 

File > Save image, then select a file 

format and give a name 

(‘BeerMug.jpg’)  

 

 

 

 

 

 


