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Today’s Lab 



About the Lab submission 

• Post your invidual web address on the webct. 

http://www3.nfb.ca/animation/objanim/en/films/film.php?sort=director&direct

or=Barker%2C+Cordell&id=17537 

 

Team project idea? Review animations at 
National Film Board of Canada 

http://www3.nfb.ca/animation/objanim/en/films/film.php?sort=director&director=Barker%2C+Cordell&id=17537
http://www3.nfb.ca/animation/objanim/en/films/film.php?sort=director&director=Barker%2C+Cordell&id=17537
http://www3.nfb.ca/animation/objanim/en/films/film.php?sort=director&director=Barker%2C+Cordell&id=17537


Surface Shaders 

 

• Ambient  

 
– Even 

illumination 
(environment 
color) 

 

– Background 
light 

 

 

 

 

 

 

 

 

 

• Diffuse 

 
– Main color 

 

– Scattering 

 

– Absorption 

 

– Mirror (~0) 

– Rough 
surface (>0) 

 

 

 

 

 

 

 

 

 

 

• Specular 

 
– Highlight 

 

– Reflection 

 

 

 

 

 

 

 

 

 

 



What is the Hypershade in Maya 3D? 

Manager 
 
• Materials 

 

• Textures 
 

• Lights 
 

• Cameras 
 
 
 
 
 
 
 
 
 
 
 
 



Shading Groups in Maya: 
 

Hypershade 

Tab menus 

 

• Materials 

 

• Textures 

 

• Lights 

 

• Cameras 

 

 

 

 

 

 

 

 

 

 

 

 



 
Shader Network 

 

 

 

 

 

 

 

 

 

 

 

A shading network is a collection of 

connected rendering nodes that defines how 

colors and textures contribute (usually with 

lights) to the final look of surfaces 

(materials). A shading network typically 

consists of any number of connected 

rendering nodes plugged into a shading 

group node. 



Materials in Maya 
 

Surfaces 

 

• Blinn, 

 

• Phong 

 

• Lambert 

 

• Etc… 

 

 

 

 

 

 

 

 

 

 

 

 



Textures in Maya 

2D Textures 

 

– File 

 

– Ramp 

 

– Etc… 

 

3D Textures 

– Cloud 

 

– Marble 

 

– etc 

 

 

 

 

 

 

 

 

 

 

 

 



Lights in Maya 

 

• Ambient light 

 

• Area light 

 

• Spot light 

 

• Directional light 

 

• Volume light 

 

• Point light 

 

 

 

 



 

Cameras in Maya 

 

 

• perspective 

 

• front 

 

• side 

 

• top 

 

 

 

 

 

 



Mathematical Shading Models 

• Phong 

 

 

 

 

 

 

 

 

 

 



Shaders 

 

 

 

(Autodesk, 2007) 

 

 

 

 



Lab Exercise 1.  
Duplicate & Assign Materials to Multiple Objects 

1. To create a cube, select Create > Polygon Primitives > 
Cube. Transform the cube through Move, Rotate and 
Scale tool. By pressing Ctrl + D, we can duplicate an 
object.  
 

2. By pressing ‘5’ (or Shading > Smooth Shade All), we can 
see the color of the cube. 
 

3. Select any cube. RMB (right mouse button) click and 
hold. Choose Assign New Material > select Blinn. To 
change curent default color, click the color cell and 
adjust the color value (HSV or RGB models available). 
 

4. Open the Hypershade (Window > Rendering Editors > 
Hypershade). 
 

5. To assign different shaders, click Blinn icon on the left 
menu which generates new Blinn shader object 
(blinn2).  To change the default color, select a couple of 
cubes to replace into new shader. While the target 
cubes selected, bring your mouse cursor on the new 
shader (blinn2), click/hold RMB, and select the Assign 
Material to Selection.   
 

6. To identify certain object(s) with specific shader applied, 
RMB on any shader object and Select Objects with 
Material. The result shows certain objects highlighted. 
 

7. Render and save your file. 
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Texture Mapping 

• Wrap image onto 3D 
geometry 

 

• Applying raster image 
information to CG geometry 

 

• Add a great detail to enhance 
realism 

 

• Avoid the need for massive 
amounts of geometric detail 

 

 

 

 

 

 

 

 

 

 

•Source: 

(Watt, 1999), (Masson, 2004) & (Park, 2004) 

 



Mapping between 
(s,t)-texel space and  
(x, y, z)-object surface space 

Texel(Texture elements): Array of pixels  
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UV Coordinate Space 

• U and V represent the two axes that lie on 

the surface. 

• N is surface normal axis that points out from 

the front of the surface. 

 

 

 



 



 



 

http://www.bigshinyrobot.com/reviews/archives/2799 

http://www.gameguru.in/action/2

009/17/watchmen-the-end-is-

nigh-to-have-voice-overs-by-

watchmen-actors/ 

Lab Exercise 2.  
Texture Mapping 101 



Ex 2. Texturing 101 

1. To adjust our workflow more into texturing, 
switch current layout inside any viewport into 
Panels >  Layouts > Two Panes Side by side 
(or Panels> Saved Layouts > 
Hypershade/Render/Persp).  Change the left 
side viewport to Hypershade (Panels > Panel 
> Hypershade) 

 

2. In the bar section of the Hypershade, go to 
Create >  2D Textures and select Checker 
function. 

 

3. Before applying any texture, please make it 
sure whether a target 3D geometry has been 
selected/highlighted (just click with Left 
Mouse Button).  Inside the Work Area of the 
Hypershade, press/hold Right Mouse Button 
(RMB) on top of the checker icon and select a 
function named Apply Material to a 
Selection. To see the effect, press ‘6’ to 
activate Hardware Texturing. 

 

4. By double-clicking on the checker node,  
Maya opens an attribute editor which 
consists of a number of attributes relate to 
the checker shader. 



5. To change the current color selection, click on the color 
cell next to Color1 (or 2) attribute. 

 

6. To manipulate the current checker pattern, select the tab 
place2dTexture1 in the Attribute Editor. 
 

7. Change values across different attributes (Rotate Frame, 
Repeat UV, Mirror U, Noise etc.), we can generate  an 
interesting pattern such as noise. 
 

8. Generate an image by pressing Render the current frame 
button.  To frame target objects inside the rendered 
image, turn on View > Camera Setting > Resolution 
Gate. To adjust current view, holding/dragging ‘Alt + 
RMB’ activates precise zoom in/out. 

 

 

 
 

 

 

 



Input connection & output connections 

 



9. Look for Bump Mapping attribute. Click the mapping button 
(tiny checker box) and choose Fractal under 2D Textures. 

 

10. Play with different parameter values in bump2d1 tab and 
fractal2 tab.  

– Bump Depth 

– in fractal1 tab, play with different values in Amplitude, 
Ratio etc. 

 

11. Save your work. 

 

12. To increase preview quality, select Rendrer >  High Quality 
Rendering Option box in the viewport menu and increase 
the Color Texture Resolution value (i.e., 512). 

 

 
 

 

 

 

 

 



Source: Indiana Jones and the Temple of Doom (Paramount Pictures), 

 LucasArts & The Internet Move Database 

Exercise 3: Set Design  
(Castle, Bridge, Cave & Cliff) 
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• Environment 
 

– Outdoor 

» Mountain, desert, ocean  

» Space, planet 

 

– Indoor 

» House, school, company building, library, 
restaurant 

 

– Microcosm 

» Inside body 
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Environment (or Level) Design in Game 
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http://en.wikipedia.org/wiki/Image:The_Great_wall_-_by_Bernard_Goldbach.jpg 

http://upload.wikimedia.org/wikipedia/commons/a/a5/Piazza_del_Campo.JPG 

http://en.wikipedia.org/wiki/Main_Page 
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• Simple Geometric Forms 

– Points (Vertex in Maya) 

– Lines (Edge in Maya) 

– Polylines 

– Polygons (Face in Maya) 

 

 

 

 

Polygons are straight-sided shapes (3 or more sides), 
defined by three-dimensional points (vertices) and the 
straight lines that connect them (edges). The interior 
region of the polygon is called the face. Vertices, edges, 
and faces are the basic components of polygons. You 
select and modify polygons using these basic 
components.  

2. Polygon modeling 



Edit Mesh > Extrude 

Mesh functions Maya 3D 

• Mesh > Sculpt Geometry 

Tool 

 

 

 

 

 

Mesh > Polygon Tool  
(User Guide > Modeling > Polygonal Modeling > Polygon selection and 

creation > Polygon creation >  ) 

• Mesh > Make Hole 

Tool 

 

 

 

 

 

 



• Edit Mesh > Split Polygon 
Tool 
 

• Edit Mesh > Insert Edge 
Loop 
 

• Mesh > Fill hole 
 

• Edit Mesh > Merge (on 
selected edges) 
 

• Mesh > Extract (on 
selected faces) 
 

• Keep Faces Together 
 



3. Constructive Solid Geometry (CSG) 
Boolean algebra 

 
(Mesh > Booleans) 

http://commons.wikimedia.org/wiki/File:Csg_tree.png 



Exercise 3.1 Castle 
Use of primitives for the main structure of a castle. 
 
1. First, let’s create a castle body. Switch to Polygons main 

menu and look for a function Create > Polygon Primitives > 
Pipe. There are two ways to generate a cube; either turn on 
Interactive Creation option or off ( if off, we must assign 
parameter values in the option box, then click on the 
viewport to generate).  This time, use the default option 
(Interactive Creation on) and interactively create a pipe by 
click and drag the mouse cursor. 
 

2. In the Channel Box, click on polyPipe1 of INPUTS, and 
change the value of Subdivisions Axis (i.e., 4 or 5 for 
pentagon).   
 

3. Before manipulating the shape (closer look to a castle), let’s 
check the orientation of pivot/center point. Double click on 
the Rotation tool and select different options in Scale Axis 
(i.e., local)  to see changes. 
 

4. To make a wall facing the front camera view, rotate 45 
degree on the Y axis  (could type under pPipe1). 
 

5. Using the Boolean operation, we can make an entrance by 
subtracting a cylinder from the cube. To make an entrance, 
first create a cylinder (Create > Polygon Primitives > Cylinder 
in the front view. Scale it on different axis to look more like a 
door.  To subtract the cylinder from the body, select the 
castle body first, then Shift select the cylinder. Apply Mesh > 
Boolean > Difference.  
 

6. Add other primitives and apply Boolean operation whether it 
works to generate more entrances. 
 
 



Can we make multiple entrances similar to coliseum in an 
efficient way (e.g. duplication)? 

 

http://en.wikipedia.org/wiki/Colosseum 



 
 

7. Create a new cylinder for a tower.  Changes 
parameters in  the polyCylinderX under INPUTS. 
Reduce the Subdivisions Axis to 10 and  increase 
Subdivisions Caps to 2. 
 

8. To extrude faces, select multiple faces on the cap 
while holding Shift to add selection.  To subtract, 
hold Ctrl key.  
 

9. Apply Edit Mesh > Extrude. To extrude on the 
positive Y axis, drag the  blue arrow up.  We can also 
apply scaling  through a small colored cube.  Scale 
down uniformly by click/hold down the center cube. 
 

10. Either turn on or off Keep Faces Together option 
under Edit Mesh, Extrude functions brings a 
different results.   
 

11. Transformation can be done through the standard 
Move, Rotate and Scale tool on the left UI (shortcut 
‘W, E, or R’) 
 

12. To redo the last activity, press ‘G’: shortcut. 
 

13. Switch to different viewports , select different faces 
and manipulate the tower shape. 
 

 
 
 
 
 
 

 
 

 
 
 
 
 

 
 
 
 
 



Step 1: Create a ground plane and cliffs 
 

1. Zoom out the current scene and draw a plane 
using the Top viewport (Create > Polygon 
Primitives > Planes). Hold and drag the mouse to 
adjust the size. 
 

2. To add more divisions, edit the attributes of the 
plane in the Channel Box (Display > UI elements 
> Channel Box/Layer Editor). 
 

3. From the Channel Box’s INPUTS section, type 20 
in the Subdivision Width and Subdivision 
Height. 
 

4. Rename pPlane1 to ground. 
 

5. To make the ground more realistic having 
bumpiness,  manipulate the surface by applying 
Mesh > Sculpt Geometry. The cursor changes to 
a brush icon. By brushing on the object, the 
shape can be easily manipulated. Play with 
different Sculpt Parameter settings  such as 
Brush Radius. 
 

6. To make a cliff or the lower ground level where 
river flows, use the Push operation on selected 
faces. 
 
 
 
 

 
 
 
 

Exercise 3.2: Polygon & Surface Modeling  
(Bridge & Cliff) 
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Step 2: Create a bridge 

 

8. By duplicating a cube, a bridge can be built. Create a cube 
and adjust the position. Go to Edit > Duplicate Special Option 
Box. Change some parameters (Number of copies, Rotate, 
Translate).  Each box next to Translate, Rotate and Scale 
indicates X, Y and Z values. Click Apply. 
 

9. To reposition the bridge, apply grouping (Edit > Group) to 
move as a group rather than an individual piece. Rename it  
from group1 to Bridge on the Channel Box.  Using the 
Manipulator tool (scale, move & rotate) ,  adjust its location. 
If it is necessary to change the center of the group reposition 
to the center, apply Modify > Center Pivot. 
 

10.  Browse other primitive objects (i.e., cylinder) and create 
more objects to complete the bridge.   
 

11. A rope can be generated by combining a circle and a curve 
through Surface > Extrude function. Create a small circle (as a 
profile) and a curve (as a path).  Select the profile object first 
and Shift select the path. Apply Surface > Extrude. 
 

12. Duplicate these objects and finalize the bridge. 
 

13. Save this file. 
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Surface > Extrude 

 

 

 

 

 

 


