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Due Dates (WebCT > Assignments) 
(2/05-midnight)  

• Individual: Lab Exercises week 1 – 3 & individual website 

• No need to change the color of the objects in Week 1 exercise 

 

(2/12-midnight) 

• Team: Storyboard  with pitch,  voice over describing about your project 

 

(2/05)   

• Quiz 1 (mixture of multiple choice and short answer quizzes from the 
textbook ONLY,  not including materials from lecture or lab slides.  

– 20 minutes starting at 6:35 

– Textbook copies available at reserved area in the library 

(2/19) 

• Individual: Port I. Modeling/Texturing/Photorealistic Rendering  

 

  

  

 



Post your individual website address on the WebCT! 
Post your files on your site, DO NOT submit throguh WebCT.  

(WebCT > Course Tools > Roster > Students) 
http://www.sfu.ca/~ysh3/iat343/exercise.html 



WebCT > Course Tools > Assignments 

• All the lab exercises in week 1, 2 and 3. 

• Submit one Maya file (“LastName_Lab01.mb”) per week by merging/importing all the exercises 
on each week. 

• Design a simple website (no need to use Adobe Flash). http://<your sfu weburl>/iat343 

• Upload rendered images (minimum three with different camera angles) and all the files (e.g., 
Maya file (mb), texture) displayed on your website. 

• Useful links:  

– SFU web page creation ( 
http://www.sfu.ca/itservices/publishing/publish_howto/SFTPpublishing.html ) 

–  Automatic forwarding ( 
http://www.htmlcodetutorial.com/document/index_tagsupp_4.html ) 

 



3 × 1 matrix.  

struct Vector3D  

{  

float x, y, z;  

};  

 

struct Vector3D  

{  

float pos[3];  

}  

Transformations 
•Matrix Multiplication 
 
•Linear transformations 
 
•Scale transforms 
 
•Rotation transforms 

 

 

 

 

 

Source: OpenGL graphics through applications / Robert Whitrow 

Ex1. 3D Math 101: Transformation  



Dot product  

Source: 
http://en.wikipedia.org/wiki/Dot_product 

Why we need it?  
Find angle between vectors. 



The cross product a × b is defined as a vector c 
that is perpendicular to both a and b, with a 
direction given by the right-hand rule and a 
magnitude equal to the area of the 
parallelogram that the vectors span. 

Source:  
http://en.wikipedia.org/wiki/Cross_product 

Cross Product 
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Dot Product & Normal Vector 

– Importance of Normal Vector 

• Lighting simulation 

• Polygon facing direction 

• Dynamics & collision 

 

 

 

 

 

 

(Xiang & Plastock, 2001) 

 



Surface Normal (Normal Vector) 

A surface normal, or simply 
normal, to a flat surface is a 
vector that is perpendicular to 
that surface. 

Source: 
http://mathworld.wolfram.com/NormalVector.html 

Source 
http://en.wikipedia.org/wiki/Surface_normal 



Source: Shaders for Game Programmers and Artists  
by St-Laurent, Sebastien  

Matrix Algebra in 3D space 
 

•Vector-Matrix multiplication 
•Matrix-matrix multiplication & associativity 
•Transpose of a matrix 
•Identify matrix 
•Inverse of matrix 

 

 

 

 

 

Source: Introduction to 3D Game Programming with DirectX 
9.0c: A Shader Approach by Frank D. Luna  
 

Review Matrix algebra! 
http://en.wikipedia.org/wiki/Matrix_(mathematics) 



User Guide > General > MEL and Expressions > Background > MEL Overview 
 

• MELTM is a scripting language at the heart of Maya. Maya’s user interface is 
created using MEL, and MEL provides an easy way to extend the functionality of 
Maya. Everything you can do using Maya’s graphical interface can be automated 
and extended using MEL. Familiarity with MEL can deepen your understanding 
of and expertise with Maya.  

• You can take advantage of MEL without learning programming. For example, it’s 
easy in Maya to perform some actions with the graphical interface, then drag 
the commands that resulted from the Script Editor to the shelf to create a 
button. However, learning MEL will open up new worlds to you, allowing you 
produce effects and save time in ways impossible using the graphical interface.  

• Here are some examples of things you can do with MEL:  

– Bypass Maya’s user interface, quickly create shortcuts, and access advanced features.  

– Customize Maya’s interface and change defaults on a scene-by-scene basis.  

– Create procedures and scripts for custom modeling, animation, dynamics, and 
rendering tasks.  

 

Using MEL (Maya Embedded Language) 



MEL (Maya Embedded Language) 

• To create a cone 
– Type cone and press Enter (try with the 

numeric keypad). 
 

• To transform the object. 
– rotate 0 0 90 <Enter> 

– move 5 2 5 <Enter> 

– scale 2 1 1 <Enter>  

 

• To execute multiple commands. 
– sphere; move 0 3 -3; scale 0.5 1 1 

<Enter> 

 

 
 
 

 
 

 



Basic structure of Programming 
 

– Data types and size 

– How to declare variable 

– Expressions: arithmetic, Boolean 

– Simple input/output 

  

 

 

 

 

Control Flow Statements  

 

 

 

 

P: 
D: 
I: 

Process 
Decision 
Iteration 

Input/output, break, continue 
if-else, switch-case, 
for, while, do-while 



1. Open Window > General Editors > Script 

Editor. 

2. Using for loop: type simple 

statement; 

 

    int $i; 

    for ($i = 1; $i <= 10; $i++) 

    { 

       polyCylinder; 

       rotate -r(15*$i) 0 0; 

       move -r 0 0 (3*$i); 

    }; 

 

 

 
 
 

 
 

 

Generating multiple objects 

To execute the script do any of the following:  
•Press the Enter key on the numeric keypad  
•Select Command > Execute.  
•Select the text you want to execute and press  
Ctrl + Enter 
 





Today’s Lab 
 

•UV maps 

•Creating Photoshop network 

 

•Reflection 

 

•Lighting 

 

 

 

 

 

 

 



Texture Mapping 

• Wrap image onto 3D geometry 
 

• Applying raster image 
information to CG geometry 
 

• Add a great detail to enhance 
realism 
 

• Avoid the need for massive 
amounts of geometric detail 
 
 
 
 
 
 
 
 
 
 

•Source: 
(Watt, 1999), (Masson, 2004) & (Park, 2004) 
 



User Guide > Modeling > Mapping UVs > UV mapping 
overview >  Introduction to UV mapping 
 

UVs (pronounced U-VEEZ) are two-dimensional texture 
coordinates that reside with the vertex component 
information for polygonal and subdivision surface 
meshes. UVs exist to define a two-dimensional texture 
coordinate system, called UV texture space. UV texture 
space uses the letters U and V to indicate the axes in 
2D. UV texture space facilitates the placement of image 
texture maps on a 3D surface.  

The process of creating explicit UVs for a surface 
mesh is called UV mapping. UV mapping is a process 
whereby you create, edit, and otherwise arrange the 
UVs (that appear as a flattened, two-dimensional 
representation of the surface mesh, over top of the 
two-dimensional image to be used as a texture as it 
appears in the UV Texture Editor.  

Mapping between 
(s,t)-texel space and  
(x, y, z)-object surface space 

Texel(Texture elements): 
Array of pixels  



User Guide > Modeling > Mapping UVs > UV mapping 
overview >  UV Texture Editor overview 



Shaders 

 
 
 

(Autodesk, 2007) 
 
 
 
 



Ex 3.1 UV Edit 
1. Open ‘Lab04s11_UV.mb’ file.  To apply an image on 

the top of the table, first select the table and focus 
zoom on the target object (press ‘F’).  Press ‘6’ to 
activate hardware texturing preview. 
 

2. Select one top face of the table and apply Lambert 
material while holding down Right Mouse Button 
(Assign Favorite Material > Lambert). 
 

3. To apply an image on the selected face, clicking on the 
map icon (checker pattern) next to Color parameter, 
which opens Create Render Node UI. 
 

4. Click on File, look for Image Name parameter and 
click on the folder icon. Select an image 
(‘top_table.jpg’) under sourceimages subfolder. 
 
 
 
 



5. Currently, the image is  not aligned properly.  To fix it, 
select the target face and open UV Texture Editor 
(Windows > ).  Under View menu, check View 
Contained Faces option.   
 

6.  Place your mouse cursor on the UV Texture Editor 
and press/hold RMB to select the UV.  Drag the 
mouse cursor to select all the UV points of the face. 
 

7. Using the regular transformation tool  to adjust the 
mapping direction, we can translate, rotate or scale 
the UV space. 
 

8. To see the results, hit the Render the current frame 
button. 
 

9. Save your file. 
 
 
 
 



Exercise 3.2: Creating Reflection 

1. Create a couple of primitives including the Polygon 
Plane. Assign different shaders which has the 
reflection parameter (e.g., Phong).  
 

2. Open the Render Settings window (Window > 
Rendering Editors > Render Settings). 
 

3. Switch to the Maya Software tab.  To improve 
rendering quality, select Production Quality of 
Quality parameter.  

4. Click on the triangle next to the Raytracing Quality. 
Click on the checkbox: Raytracing. Play with different 
values in the Reflection. To see a quick result, hit the 
Render the current frame button.  
 

5. To generate refraction of the target object, select the 
object first, and  open the material shader  section of 
the object. (Ctrl + A).  Modify Transparency value to 
high (drag the slider to the right),  and turn on the 
Refractions option in the Raytrace Options. Play 
with the Refractive Index value to see different 
results. 
 
 
 
 
 
 
 

©Kyung Jae Lee 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Three Point Lighting 

Key Light 

Fill Light 

Back Light 

Reading material: Jeremy Birn 
http://www.3drender.com/light/3point.html 
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Light Types in Computer Graphics 



Lights in Maya 

 
• Ambient light 

 
• Area light 

 
• Spot light 

 
• Directional light 

 
• Volume light 

 
• Point light 

 
 
 
 



Ambient light 



 

Spot light 



 

Spot light with lens flare 
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Spot Light Attributes 

 



Decay Rate 

 
• No Decay : Light reaches 

everything 
 

• Linear: Light intensity decreases 
proportion to distance (1/d) 
 

• Quadratic: Light simulation 
close to real life (1/d*d) 
 

• Cubic: Faster decay rate than in 
real life (1/d*d*d) 
 
 
 
 
 
 
 
 



 



Texture mapping on Color attribute 



Exercise 3.3: Lighting 
Spot Light 

 
1. Open Lab04_LightingAgent.mb file. 

 
2. This scene has only one light, 

pointLight_Torch. To see the light effect in 
the Perspective viewport, click on the target 
view and press 7. 
 

3. First, let’s create a spot light. Select the 
Create > Lights > Spot Light > Option Box. To 
create the spot light at the center of the grid, 
uncheck Interactive Placement option. Click 
Create button. You can see the spot light icon 
(a cone with an arrow) . 
 

4. To place the spot light pointing down the 
character, use different navigation tools (View 
> Camera Tools) in the viewport to achieve 
precise control over camera position as well 
as apply different transformation tools 
(Move) to adjust the position, rotation and 
the direction of the Spot Light. 
 

5. Besides using the standard TRS (translation, 
rotation, scaling) tool, the Manipulator tool 
(Modify > Transformation Tools > Show 
Manipulator Tool) brings two manipulators 
(Look-at point & Eye point) to position and to 
aim the light accurately. If it is necessary, 
adjust the positions of both manipulators by 
click/drag. 
 
 
 
 



Decay Rates, Shadow & Color 
 

5. Depending on how light diminishes with distance 
(decay rate), it brings different mood as well as 
visual information. In the Spot Light Attributes 
section (Ctrl + A to open it), there are four 
settings for controlling Decay Rate. Select No 
Decay or Quadratic and render out to see the 
difference. 
 

6. Do you see any shadow? To project the shadows 
from this spot light, look for Shadow section and 
turn on Use Depth Map Shadows in Depth Map 
Shadow Attributes. This option also prevents the 
light pass through by the first object it 
encounters. 
 

7.  To reveal the appearance of the light beams (i.e., 
fog or dust), click Map button next to Light Fog in 
the Light Effects section. Render out to see the 
effect. Adjust the color in Light Fog Attributes to 
generate an interesting color mood. 
 

8. Other attributes to consider; 
• Cone Angle 
• Dropoff (intensity control) 
• Penumbra (softness along the edge)  

 
 



Decay Regions & Map 
 

9. To have more precise control over decay, 
Maya provides Decay Region tool that 
could divide the region into sub-regions. 
Let’s first turn on the Use Decay Regions 
in Decay Regions. Also, display the Decay 
Region manipulators (Display > 
Rendering > Camera/Light Manipulator > 
Decay Regions).  
 

10. Using Move tool, you could interactively 
reposition the distance of each region. 
Click and drag each region (manipulator 
ring). Play with Intensity value to 
generate different moods. 
 

11. Rather than using simple color for the 
light, you could map color into an image 
file. Click Map button next to Color 
attribute, select the File button, click 
Folder icon next to the Image Name then 
load an image file. (i.e., nebula). Test the 
effect. 
 

12. If you want to remove the map, RMB click 
on the Color label and select the Break 
Connection. 
 
 
 



Point Light & Lens Flare 
 

13. Light Glow attribute provides optical 
effects (Glows, Halos, and Lens Flares). 
Rather than adding this effect on the 
existing lights, let’s create another light ( 
Create > Lights > Point Light). Position 
this light above the torch.  
 

14. In the Light Effects attributes, click Map 
button next to Light Glow. It opens 
Optical FX attributes that include Glow, 
Halo, and Lens Flare. Turn on Lens Flare 
option. Render it out to see the effect. 
You could lower the Intensity of the Point 
Light Attributes. 
 

15. Adjust number of attributes to make the 
scene more appealing.  

• Glow Type 
• Halo Type 
• Halo Color 
• Halo Intensity 
• Etc… 

 
 
 

 
 

 
 
 
 



Area light 
 

16. In Star Wars, Luke Skywaker use the 
lightsaver. To simulate this effect, first 
create a stick object (i.e., sword or any 
weapon of your choice).  
 

17. Add an Arear light ( Create > Lights > 
Area Light). Reposition the area light 
close to the center of the light. Transform 
(i.e., scale) the shape of the area light 
similar to the stick.  
 

18. Adjust number of attributes (i.e., color) 
to make the stick interesting. 
 
 

 
 
 

 
 
 
 



Rendering Quality 
 

16. The Render Settings menu has a set of 
global attributes to control the quality of 
rendering. Also, it provides different 
settings relate to rendered images. To 
open this menu, choose Window > 
Rendering Editors > Render Setting. 
 

17. Under Common tab, choose a type of 
Image formats, Image Size and 
Renderable Camera.  
 

18. Make it sure the location of a saved 
image (Edit > Change Project Image 
Directory).  
 

19. Switch to Maya Software tab. To improve 
the quality of rendered images, Maya 
provides Anti-aliasing Quality option. 
Change Quality option and Edge anti-
aliasing option to higher quality. 
 

20. Render under different settings and 
compare the image qualities of the 
rendered images. 
 
 
 
 

 
 

 
 
 
 



 



User Guide > Modeling > Mapping UVs > UV mapping overview >   
UV Texture Editor overview 

User Guide > Modeling > Mapping UVs > UVs windows and editors 
reference > UV Texture Editor >  UV Texture Editor toolbar 



Learning Resources > Tutorials > Getting Started with Maya > Polygon 
Texturing >  Introduction 


