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Due date change 

(9/23) Midnight Sunday 

• Team: Script, team website, & sketch with 

description (character & environment sketch)  

 

• Individual: individual website (just a link to your 

site). 

(9/30) Midnight Sunday 

• Team: Storyboard with pitch 

• Individual: Post your Lab Exercises (week 1 – 

3) on individual website. 



Script, Character & Environment Sketch 

Examples (Due 9/23) 

• http://www.sfu.ca/~bva7/cave_man_janitor/ 

• http://www.sfu.ca/~yca50/IAT343/stuckOnMars/html/stor

y.html#character_sketch 

• http://iat343teamnameless.weebly.com/character--

environment-concepts.html 

 

Here are some examples for Team sites 

( http://www.sfu.ca/~jpw3/iat343/team/index.html ) 

( http://www.sfu.ca/~jla194/fall10/343/teamjas.html ) 

( http://www.sfu.ca/~yka34/IAT_343/team_site/ ) 

http://www.sfu.ca/~bva7/cave_man_janitor/
http://www.sfu.ca/~bva7/cave_man_janitor/
http://www.sfu.ca/~bva7/cave_man_janitor/
http://www.sfu.ca/~yca50/IAT343/stuckOnMars/html/story.html
http://www.sfu.ca/~yca50/IAT343/stuckOnMars/html/story.html
http://www.sfu.ca/~yca50/IAT343/stuckOnMars/html/story.html
http://iat343teamnameless.weebly.com/character--environment-concepts.html
http://iat343teamnameless.weebly.com/character--environment-concepts.html
http://iat343teamnameless.weebly.com/character--environment-concepts.html
http://iat343teamnameless.weebly.com/character--environment-concepts.html
http://iat343teamnameless.weebly.com/character--environment-concepts.html
http://iat343teamnameless.weebly.com/character--environment-concepts.html


Class Resources 

• Maya documentation:  
– Access through Maya application: Help > Learning 

Resources > Tutorials >   

 Or go to 
 http://download.autodesk.com/us/maya/2011help/index.html 

 

– Online including tutorial files  
 ( http://usa.autodesk.com/adsk/servlet/index?id=9502844&siteID=123112&linkID=9242256 ) 

 

Theory & Training 

http://download.autodesk.com/us/maya/2011help/index.html
http://download.autodesk.com/us/maya/2011help/index.html
http://download.autodesk.com/us/maya/2011help/index.html
http://usa.autodesk.com/adsk/servlet/index?id=9502844&siteID=123112&linkID=9242256
http://usa.autodesk.com/adsk/servlet/index?id=9502844&siteID=123112&linkID=9242256
http://usa.autodesk.com/adsk/servlet/index?id=9502844&siteID=123112&linkID=9242256
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1. Surface modeling (e.g., NURBS method) 
• Lofting (profile curve & path) 

 

2. Polygon modeling 
 

3. Constructive Solid Geometry (CSG) 
• Boolean algebra 

 

4. Physically-based modeling 
• Mass-Spring Model (e.g. cloth) 

 

5. Volume visualization 
 

6. Procedural modeling 
• Particle system 
• Fractal system 

 

7. Image-based 3D construction 
8. Other approaches 

 
 

 
 
 
 

 

Modeling Methods (CG Techniques) 

•Solid object 
 

•Non-solid object  



Source: Wedding-Favours.ca 

Source: Starbuckcoffee.net 

Source: ikea.com 

1. Curve-based Surface Modeling 

http://www.mydreamwedding.ca/search/irish+traditions


Curved based modeling (parametric curved surfaces)  
contains mathematically defined elements and each 
coordinate is a function of one or more parameters 
such as a control hull, control points, tangent points, 
knots, and weights (Kerlow, p117 & p139-140). 

Source: 

http://www.erimez.com/misc/Softimage/tutorials/si_help/

introduction/si_uk_model_intro.htm 

http://www.erimez.com/misc/Softimage/tutorials/si_help/introduction/si_uk_model_intro.htm
http://www.erimez.com/misc/Softimage/tutorials/si_help/introduction/si_uk_model_intro.htm
http://www.erimez.com/misc/Softimage/tutorials/si_help/introduction/si_uk_model_intro.htm
http://www.erimez.com/misc/Softimage/tutorials/si_help/introduction/si_uk_model_intro.htm
http://www.erimez.com/misc/Softimage/tutorials/si_help/introduction/si_uk_model_intro.htm


• Curves 

– CV (control vertices) 

• CVs (control vertices) control how 
the curve is “pulled” from a 
straight line between edit points. 
(1: box, 2.’U’ and the rest: dot) 

– EP (edit points) 

• Connection points (small ‘x’ in Maya) 

– Hulls 

• Lines between CVs 

– Isoparms 

• Lines along the surface 

– Patches 

• Enclosed area by four adjacent isoparms 

 

 

 

 

 

Components of NURBS curves 
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• Revolve technique 
• Sweeps out a surface by revolving a 

profile curve around a pivot point. 



Surface Modeling 

Surface > Planar 

 

 

 

 

 

 

 

Surfaces > Bevel  

Creating an extruded surface with a beveled 
edge from any curve, including text curves and 
trim edges.  

Creating a planar (flat) surface within a 
boundary curve.  

• Surface > Extrude 

 

 

 

 

 

 



Modeling 

• Surface > Birail 

 

 

 

 

 

 

 

• Surface > Boundary 

 

 

 

 

 

 

• Surface > Revolve 

 

 

 

 

 

 

• Surface > Bevel 

 

 

 

 

 

 



Surface Modeling 

Surface > Planar 

 

 

 

 

 

 

 

Surface > Loft 

 

 

 

 

 

 Surface > Extrude 

 

 

 

 

 

 

Surface > Birail 

 

 

 

 

 

 

 

Surface > Boundary 

 

 

 

 

 

 

Surface > Revolve 

 

 

 

 

 

 

Surface > Bevel 

 

 

 

 

 

 



Creating NURBS curves 

User Guide > General > Basics > Basics 
Menus > Create >  Create > EP Curve Tool 

Learning Resources > Tutorials > Getting Started with Maya >   
NURBS Modeling 



Face Modeling Techniques  

Curve/surface based: NURBS 

Source: 

http://www.3drender.com/jbirn/ea/HeadModel.html 
 1-14 

http://www.3drender.com/jbirn/ea/HeadModel.html


•http://www.amazon.com/Childrens-Cooking-Kits-Cookie-Cutters/dp/B000TGQOLE 
•http://www.thegreenhead.com/imgs/abc-cookie-cutters-3.jpg 

Image source: 
•http://fantes.com/images/8205cookie_cutters.jpg 

•http://www.geekalerts.com/tag/cookies/ 

Lab Exercise 3.1: Cookie Cutter 



Lab Exercise 3.1: Cookie Cutter  
Outline curves, Planar & Bevel 
 

1. First, switch to Surfaces main menu. Using the Top 
orthographic view, draw a circle: Create > NURBS Primitives > 
Circle. By holding ‘x’, we can snap on the grid. 
 

2. On the right side of UI, click on the label under INPUTS > 
makeNurbCircle1 on the Channel Box and change some 
parameter values (e.g., radius, sweep etc). If the Channel Box 
is not shown, click on the Show or hide the Channel Box / 
Layer Editor.. Add more circles and place them inside the first 
one.  
 

3. To change the number of points on the circle, change Sections 
value under the makeNurbCircle1 under INPUTS. To see the 
change, switch to the component mode (press ‘F8’ switch 
between the object and component)  
 

4. To manipulate the shape of the circle (through the circle’s 
components: points), RMB click on the circle and select the 
Edit Point. After selecting multiple points while holding the 
Shift button, use the transformation tools (Move, Scale or 
Rotate) to change the shape.  
 

5. Instead of using simple circle tool, add/draw a number of 
shapes (i.e., heart, star) through the curve tool (Create > EP 
Curve tool).  Select the new shape and make it sure the shape 
having a closed space (Edit Curves > Open/Close Curves under 
Surfaces Module).  
 

6. Use the transformation tool to refine the shape. Pressing 
‘Delete’ reduce point(s), but also slight changes on the overall 
shape. Check the center point whether repositioning of the 
pivot point is necessary (Modify > Center Pivot) 
 

©Kyung Jae Lee 

Surfaces main menu 

Create > NURBS Primitives > Circle 



7. Switch to the perspective view (bring the mouse cursor in 
the target view, hit the spacebar to maximize the viewport).  
 

8. To extrude a surface from the curve, select the curve(s) and 
apply Surface > Bevel. Open an Attribute Editor (Ctrl + A) . 
Click on the bevel1 tab and adjust some parameter values 
(i.e., Width, Depth). 
 

9. To see the list of the objects, go to Windows > Outliner. We 
can rename by click/type on the current text.  
 

10. To create a flat surface from curve(s), select the curve(s) and 
apply Surface > Planar.  Compare different results whether 
selecting single or multiple curves. 
 

11. Using the Outliner, select the newly created surface (i.e., 
planarTrimmedSurface2) and adjust its position. 
 

12. We can reuse the curves to generate another 3D surface. 
 

13. Save your file ‘yourLastName_initial_3_1.ma’. 

14. . 
 
 

©Kyung Jae Lee 



Could we build a guitar based on previous 
exercise? 

Source: 

http://en.wikipedia.org/wiki/File:Guitar_1.jpg 



Week 1 
Introduction to Animation & Modeling  
Reading:  

 Kerlow: Ch 2 (p49 – 90) &  
 
Ch 3 (93 – 114),  

 Xiang ch 1(p1-5) & ch4 (p68—77)  
  
Week 2  
Modeling II & Scene Composition  
Reading:  

 Kerlow: Ch 4 (p115 – 138)  
 Xiang: ch6 (p114-118), ch 7 (128-133) & 

ch 9 (p174-178)  
  

To improve your modeling skills, read these 
chapters (review the syllabus) 



Source: Wedding-Favours.ca 

Source: Starbuckcoffee.net 

Source: ikea.com 

Lab Exercise 3.2: Curves & Surface Modeling  

http://www.mydreamwedding.ca/search/irish+traditions


Ex 3.2. Curves & Surface Modeling (Beer Mug) 
Step 1: Display a reference image 
1. Create a new project (File > New Project) and 

generate subfolders  through pressing the Use 
Default button. Save your file first (File > Save 
Scene As , select the Maya binary). Open a web 
browser and find a reference image (i.e. glass) ,or 
download the image, ‘beer_mug.jpg’, from the 
Week 2 folder. Save it under the sourceimages sub-
folder. 
 

2. To display the image in the Front view window, 
apply View > Image Plane >Import Image function 
in the Front view menu. Select the saved image.  
 

3. To adjust the position of the reference image in the 
virtual space, open an attribute editor of the 
currently selected object (Open it through either 
accessing Display > UI Elements > Attribute Editor, 
or go to the View > Image Plane >Image Plane 
Attributes > select imagePlane1 in any viewport 
menu. 
 

4. Adjust the position of the image by changing 
parameter values (x, y or z coordinates: e.g., 0.000, 
11.000, -10.000) of the Center in the Placement 
Extras section.  
 

5. Making the reference image semi-transparent 
(Alpha Gain value), it makes easier to build 3D 
geometry.  
 
 
 
 
 

http://www.mydreamwedding.ca/search/irish+traditions


Step 2: Create an outline curve and construct a surface 
6. To draw an outline curve of the beer bug, switch to ‘Surfaces’ 

module (press F4 key). 
 

7. Before generating points for the outline curve, review the 
curve tool options through Create > EP Curve Tool > Option 
Box. Instead activating the straight curve (1 Linear), select the 
Curve Degree as 3 cubic for the smooth curve. 
 

8. Using an orthographic view (front), draw a curve which shapes 
the outline of the half of the cup. To snap a point to the grid 
cell, press and hold ‘x’ key while drawing.  
 

9. To refine the shape of the surface, click and hold RMB (right-
mouse button) and select either Edit Point or Control Vertex. 
Using the Move Tool, reposition an individual vertex to 
reshape. By pressing ‘Delete’ key, erase an unnecessary vertex. 
Also, press ‘z’ for undo. 
 

10. To add points, press and hold right-mouse button and drag the 
mouse cursor on the Edit Point mode. Under Surfaces module, 
Edit Curves > Insert Knot > Option Box. Select Between 
selections. Select two points from the curve, then press the 
Apply button. Another approach is  using the Add Points Tool. 
 

11. To construct a 3D surface covering an entire curve, it is 
important to switch back to the whole Object Mode selection 
by pressing F8.  Before generating a 3D surface from the curve, 
adjust a default option in the Surface > Revolve > Option Box.  
To revolve around the Y-axis, select ‘Y’ in Axis preset. Click 
Apply. 
 

12. To change the shading of the model, press either 5(flat 
shading) or 4 (wireframe). 
 
 
 
 



Soft selection (on/off) 

 



Step 3: Create a mug handle 
 

13. By pressing the spacebar, maximize the perspective 
viewport. To add a mug handle, we will add more 
divisions on the surface. Hold RMB and select Isoparm. 
By using Select Tool, click an existing isoparm line 
(change to a red line) and hold/drag the isoparm line to 
the location where you will add a new line (change to 
yellow line). Release the mouse cursor.  
 

14. Select the Edit NURBS > Insert Isoparm. To add more 
lines, repeat previous step until the surface has enough 
segments. To change the shading of the model, press 
either 4 (wireframe) or 5(flat shading). 
 

15. To create a handle for the beer mug, we will add a circle 
on top of the surface being used as the base profile 
curve.  Switch to the Object Mode and apply Modify > 
Make Live function from the top menu bar which 
converts the selected surface to a live surface. 
 

16. Switch to the side view and zoon into the handle area. 
Draw a circle by Create > NURBS Primitives > Circle on 
the cross point between lines. While having the Make 
Live mode, a curve can be drawn on top of the surface.  
Different snapping options provides more control to 
adjust the position of the curve.  
 

17. To bring the surface status back to the default state, 
apply Modify > Not Live.  Reposition the circle where  it 
matches the start of the handle in front view. 
 
 
 
 
 



 

18. Switch to the Front view. We will draw a curve 
which will be used as an outline of the handle.  

 

19. Select the Create > EP Curve Tool. Draw an 
outline of the handle close to the center 
location of the curve.  

 

20. To generate a 3D surface, select both the Circle 
and the curve through holding Shift key. Select 
the Surface > Extrude > Option Box. Set option 
parameters similar to the image on the left 
(turn on the following options: Tube, At Path, 
Path Direction). Press ‘Apply’ button.  

 

21. Open an Outliner (Window > Outliner) to see 
all the objects in the scene. 

 

22. To group two surfaces, select both objects and 
go to Edit > Group. Change the default name 
(group1) to on your own (i.e., BeerMug) 

 

23. To manipulate the 3D shape, select the Edit 
Point of the outline curve. Grab number of 
points and use Move, Rotate or Scale tool to 
deform the shape. 

 

 

 

 

 

 

 

 

 



Surface Modeling 

Surface > Planar 

 

 

 

 

 

 

 

Surface > Loft 

 

 

 

 

 

 Surface > Extrude 

 

 

 

 

 

 

Surface > Birail 

 

 

 

 

 

 

 

Surface > Boundary 

 

 

 

 

 

 

Surface > Revolve 

 

 

 

 

 

 

Surface > Bevel 

 

 

 

 

 

 



Step 4: Save & Render 

 

24. If you haven’t saved your file, save it by 
File > Save Scene as. And name it 
‘yourLastName_initial_3_2.ma’. 

 

25. To render an image in the perspective 
view, click your mouse cursor in the 
perspective viewport  to activate. 

 

26. Press ‘Render Current Frame’ icon on the 
toolbar to bring up the Render View. To 
save an image, go to the File > Save 
image, then select a file format and give a 
name (‘yourLastName_initial_3.2.jpg’)  

 

27. Play with other surface modeling 
techniques (i.e., Surface > Loft, Surface > 
Boundary) and add/create another object 
for the lab submission based on the 
surface techniques (i.e., wine glass) . 

 

 

 

 

 

 

Learning Resources > Tutorials > Getting Started with 

Maya > NURBS Modeling >  

Lesson 3: Lofting curves to create a surface 

http://download.autodesk.com/us/maya/2011help/files/WS73099cc142f48755-4bc38c931187aa80bc9-3587.htm
http://download.autodesk.com/us/maya/2011help/files/WS73099cc142f48755-4bc38c931187aa80bc9-3588.htm
http://download.autodesk.com/us/maya/2011help/files/WS73099cc142f48755-4bc38c931187aa80bc9-3589.htm
http://download.autodesk.com/us/maya/2011help/files/WS73099cc142f48755-4bc38c931187aa80bc9-3589.htm
http://download.autodesk.com/us/maya/2011help/files/GS_NURBS_Modeling.htm


Selection options 

 


