CSIL Windows Known Issues Page

Note: On this page, there are many references to various servers, click here to find their names; and please replace username with your own SFU login.

top


System Access

 

I know U: is my home directory, but sometimes I can't access it. Help!

There are two usual reasons:

  • You've reached your disk quota limit; you can't write on it before you clear out some space (delete some files).
  • The U: drive isn't correctly mapped to your home directory. Please reboot the computer and try again.

Other symptoms of the similar issue (which a reboot will help):

- manually mapping to U: fails

See the next Q&A for other options.

top

There is 1 TB free space on U: drive; why I could not create a 10MB file?

This is a known issue: the 1TB free space you see is shared among thousands of SFU users, not only to you. You may have reached the quota limit on your SFU home.

To check out how much space you've used on your sfu home, please select all of the files and folders (include hiden and system objects) on you U: drive and check the properties. Once you got this number, you could calculate the real free space you have on your sfu home by check againt the quota limit on IT Services site.

top

I cannot create file/folder on U: drive, what I could do?

The symptoms:

the U: is properly mapped

there is space available on U:

user could not create file/folder on U:

within the SSH window connects to a CSIL CPU server, they cannot create file/folder in their sfuhome/ .

this may happen to other people too.

This means there are technical issues with the ITS' file server.

In this case, the CS helpdesk cannot assist you; please contact help line of SFU asap. You will find more information on this page.

top

I can't get the system running properly; Helpdesk says maybe my profile has become corrupted.

The Windows User Profile is a system level file containing some of your personal preferences such as your Windows Explorer settings, desktop appearance settings, DSN, environment settings, etc. Every CSIL Windows user is using roaming profile with folder redirection.

There are numerous factors that can cause the profile to become corrupted: exceeding your disk quota for profile, an incomplete logoff, even a slow network connection. To restore your profile back to its original settings, you must email helpdesk. Unfortunately, all modifications you've made to your profile are wiped out after we reset it.

There is a hard quota of 30 MB on your profile. This should be sufficient for any configuration changes and links that you may want to put into your menus or onto your desktop. However, if you put a file (not a link) in your "Documents" or "Desktop" folders, the entire file is placed into your profile directory and you may end up exceeding your profile quota. Note: This can lead to a failure to update your profile. We strongly recommend that you do not put anything other than shortcuts into these two folders.

top

I can't access the Internet.

This probably means your profile has become corrupted.

top

Sometimes the system won't allow me logoff - it complains that my profile has exceeded the quota. What should I do?

As you've known, we are using roaming profile for all users in CSIL - and there is a quota limitation on each user's profile size. When you logoff from a CSIL Windows system, the system will try to move the local cached user profile to network storage. If the local cached user profile could not be fit into the network storage, data loss will occur.

Since the system must ensure there is no data loss, it has to prevent user from logoff - user must clean up profile so it will fit and then user could logoff.

So, you must clean up your profile:

first, check out this Q&A to clean up the redirected portion of your profile.

Then, clean out "c:\users\username" folder, this folder should be less than 50 MB.

If you don't know how to do this, please try this:

Please hit Ctrl-Alt-Del to get the "Windows Security" window, and then click on the "switch user" option. (Please note - this is the only time to use this method in CSIL )

Now, hit Ctrl-Alt-Del again to get the "Windows Security" window, and then click on the red power button and select "Restart" - ignore all the warnings and force restart.

(The system will restart and the local cached profile will be cleaned - we have implemented a special program for this.)

Please note: do not hold down the power button to restart or shutdown the computer - we have seen too many corrupted systems and we have to rebuild them from scratch!

top

Sometimes the system stops responding when I logoff. What should I do?

Please hit Ctrl-Alt-Del to get the "Windows Security" window, and then click on the "Task Manager" button. The Task Manager will pop up. Find any application whose status is "Not Responding" and end the task. After you do this, the logoff procedure should continue.

The "switch user" is not a valid option in CSIL - this action has created countless issues. One example would be: user' profile grows too big and results the user could not logoff before clean up.

Note: Make sure you see the logon screen before you leave the terminal! If you don't logoff properly, anyone else sitting down at that workstation will be able to continue to use the computer under your name (use your CCN account) and has full access of your personal data.

top

I can't open my project by double-clicking the project icon on the U: drive.

There are two usual reasons:

  • The application associated with the file extension is broken. Windows can associate particular file extensions with particular applications. You can make these associations yourself; though many come with the applications installed on the system (e.g. .doc for MS-Word, .psd for Photoshop).

    Try to open the project inside the application.

  • Your profile has become corrupted.

top

I get an "Open File - Security Waning" dialog box when I try to run an application. What should I do?

If you know the application is legitimate, you can just click "Open" to run it.

If what you click is a shortcut which provided by the system, you can do this to prevent the dialog from appearing:

Open Internet Explorer
Click on menu Tools -> Internet Options
Click tab Security
Select Local intranet and then click Sites... button
Click Advanced... button and add the following web sites to the zone:

file://freesia.csil.sfu.ca
file://freesia
file://cypress.csil.sfu.ca
file://cypress
file://sphinx.sfu.ca

Click OK buttons to save the settings.

If the dialog box still appears after you do this, please email helpdesk for further help.

top

I get license error while accessing CSIL Windows Terminal Server. What should I do?

Please follow the instructions on this page.

Technote: the error message: "The remote session was disconnected because there are no Terminal Server client access licenses available for this computer. Please contact the server administrator."

top

Some applications could not to write to "freesia". What should I do?

"freesia.csil.sfu.ca" is the CSIL Windows file server stores users' profiles. Every CSIL user has 120MB on this server.

Unfortunately, some applications write their configuration files (or worse, even the executables) to user's profile folder.

When there is an error message says it could not write to '\\freesia\userdata\username\", the most possible reason is: there is no enough free space for you.

You may try the following steps:

1. Move all files from the "Desktop" and "Documents" folder to U: - the home directory for storing data. This should clean up enough space.

2. Use the Windows Explorer (no the Internet Explorer), navigate to

"\\freesia\userdata\username"

folder and check to see if there are application folders are huge in size. In general, you could safely delete those. (Most of these folders and/or files are hidden.)

3. Change the permissions on folder

"\\freesia\userdata\username"

to ensure you have Full access to any folders and files.

4. And please check and empty the recycle bin on your desktop to reclaim the free space.

If these clean up did not fix the problem, please contact helpdesk.

top


Development Tools: Microsoft Visual Studio

 

VB crashes when I load my project - it worked yesterday on the same computer.

Please see here for details.

top

I get an "access denied" error when I load my project in VB, and some of the functions are missing.

Please see here for details.

top

I can't add new component into my VB project.

Please see here for details.

top

I have a C++ project, but VC++ won't compile it.

Please find answers here.

top

When I use VC++, I always get "Not enough space", or "Disk is full" error messages.

Please find answers here.

top

I cannot create/open/debug Visual Studio solutions. What should I do?

Please find answers here.

top

Keyboard is not working under Visual Studio! What should I do?

Please find answers here.

top

Visual Studio does not function as expected! What should I do?

Please find answers here.

top

My Visual Studio program gets permission error! What should I do?

Please find answers here.

top

I cannot create/open/debug Visual Studio solutions on CSIL Terminal Server. What should I do?

This is a known issue of CSIL. Click here for more information.

top


Development Tools: Jave: JDK, JRE and Java IDEs

 

Where JDK is installed on CSIL Windows systems?

On all CSIL Windows systems, we have JDK installed here:


C:\Program Files\Java\jdk

The JDK documents are under

C:\Program Files\Java\jdk\docs

Technote: We have dropped support for 32bit JDK/JRE. All of our Windows systems are using 64bit JDK/JRE on the 64bit OS. If you noticed any compatibility issue with certain applications, please inform the application vendor for updates.

Please read this page to find out more on running java applications - aka java.exe command line options.

top

I cannot compile Java in Jcreator. What should I do?

The most common reason is that the Jcreator does not have JDK home path setup properly. Please follow these steps:

  • navigate to menu Configure -> Option
  • on the left pane click JDK Profiles
  • delete all existing profiles
  • click button New...
  • navigate to folder C:\Program Files\Java\jdk
  • for Documents folder, use folder C:\Program Files\Java\jdk\docs
  • click button OK a few times to save the settings
  • try to compile your program

top

I have trouble browse pages contain JavaScript on CSIL Terminal Server. What should I do?

There might be some issues with Java and JavaScript on our CSIL Terminal Server. The cause might be the server's operating system is 64bit. For more information, read this page and this page.

The workaround: use Mozilla Firefox or Internet Explorer (x86).

top

I have got some compatibility issues with Java environment. What should I do?

Since Summer 2015, we have Java (JDK & JRE) 8 64bit installed on all CSIL Windows systems.

Please check out the features of JDK 8 and the release note of Java 8.

If you grab some sample codes from the Internet, please make sure it is compatible with Java 8 64bit in CSIL.

Please chat with the instructor if you could not resolve the compatibility issues on your own.

Extra notes: we plan to upgrade Java support to version 10 stars Spring 2019. If you have any concerns, email us now.

top


Development Tools: Netbeans

 

Netbeans says "JVM creation failed". What should I do?

This is a known issue with Netbeans.

Please try to launch Netbeans by using the following commandline (please note: this is a single line):

  "c:\program files\netneans\bin\netbeans.exe" -J-XX:MaxPermSize=128m

You may want to save this as a shortcut on your desktop.

Here is a bug report.

top


Development Tools: Eclipse

 

I cannot create workspace under Eclipse, What should I do?

The default workspace path may look like this:


\\??? \username\eclipse\workspace


Unfortunately, Eclipse does not recognize this UNC (short of Uniform Naming Convention) path.

To create your own workspace, simply use MS-DOS style path like

U:\eclipse\workspace

top

I have trouble using Eclipse. What should I do?

The possible symptoms include (but not limit to): cannot create new project; many menu items are grayed out; popup dialog shows errors; etc.

Please follow these steps:

  • close all instances of running eclipse
  • launch Windows Explorer
  • goto the folder:
    \\freesia\userdata\username
  • delete this folder: .eclipse
  • delete this folder as well (if you have it): eclipse

If these steps did not fix the issue, please try to follow the instructions listed in this Q&A to clean up your profile.

top

I have trouble using Eclipse for Android development. What should I do?

There are some points to be noted here:
Firstly:

  • Launch Windows Explorer, right click Computer, select Properties
  • in the newly opened window, navigate on left pane, click Advanced system settings
  • in the newly open dialog box, click button Environment Variables...
  • in the newly open dialog box, click button New... just under "Variables for ..." text box
  • in the newly open dialog box, type ANDROID_SDK_HOME in Variable name box, \\freesia\userdata\username in Variable value box.
  • Click OK a few times to save the settings

Secondly:

  • Launch Eclipse
  • Navigate to Menu Window -> Preferences
  • on the left pane, click Android
  • on the right pane, type C:\Program Files (x86)\Android\android-sdk for SDK Location
  • click button OK
  • Navigate to Menu Window -> Adndroid SDK and AVD Manager
  • in the newly open dialog box, create a new virtual device, then emulate it

Just be patient, the emulator is on the slow side...

top


Development Tools: Python

 

IDLE (Python GUI) won't start! What should I do?

Sometimes when IDLE starts, it prompts the following error message:


Subprocess Startup Error: IDLE's subprocess didn't make connection. Either IDLE can't start a subprocess or personal firewall software is blocking the connection.

Here is the workaround (a fix is under research):

  • launch Windows Explorer
  • find (or create) a file with .py extension
  • right click this file, select "Edit with IDLE"

Now, the IDLE (Python GUI) should start.

top


Multimedia

 

When I play a media file, the system asks me to download the codec. What should I do?

Go to menu item "Tools", click "Options", UNCHECK "Enable automatic codec download".

Only system administrators can download codec and install it. Please email helpdesk to request the codec you need for your course work. Please give the location of your media file when you make your request.

top

Every time I start the Media Player, it asks me type a password to connect to internet. Can I change this?

Yes, you can.

Go to menu "Tools", click "Options", uncheck "Start player in Media Guide".

top

When I play any sound (wave, streaming audio, etc.), it plays it much faster than it should.

The system is experiencing a problem - the audio driver and/or the codec are not working properly. Please email helpdesk to get it fixed.

top

When I run Photoshop, I can't get the help running.

Please use the shortcut, "Photoshop Help" instead. It's located at the "Start Menu\Adobe"

top

Where I can find instructions on the SB Audigy sound card?

Here is a figure of Audigy's front panel.

Here is a figure of Audigy card itself.

You can click here to get the manual (PDF format).

top

Ulead Movie Factory runs very slow and I get "not enough space" error. What should I do?

Please change the temporary folder of Ulead Movie Factory to c:\temp

Also, always create a DVD ISO in advance then burn to a DVD disk by using ImgBurn.

top

I cannot export video by using Adobe MPEG Encoder within Premiere. What should I do?

There are few issues with the Adobe MPEG encoder:

  • it requires one license per user
  • it requires the user to have administrative privilege to use the encoder

So, please do not use Adobe MPEG encoder to export movies.

For making the final movie, please use Premiere menu: File -> Export Timeline -> Movie...
And please select a proper video encoder for your movie (DivX is recommended).

top

Cyberlink PowerDirector crashes and I could not run it at all. What should I do?

In most of the cases, this is the result of a corrupted PowerDirctr config folder.

Please follow these steps:

  • launch Windows Explorer
  • goto the folder:
    \\freesia\userdata\username
  • locate the sub folder: AppData\Roaming
  • delete this folder: CyberLink

top


Printing

 

I want to save my file to PostScript instead of sending it to the printer.

When you print, there is a check box on the dialog box read "print to file".  When you check this box and hit print, a file will be generated instead of paper output. The generated file is basically a PostScript file.

There is NO CHARGE if you save as a PostScript file.

top

I want to save my file to PDF instead of sending it to the printer.

We have a pseudo printer called "PDF 24 PDF" installed on every CSIL Windows system. When you print to this "printer", you will get a PDF file (the file name and the location must be specified) instead of paper pages on a real printing device.

There is NO CHARGE if you print to this PDF pseudo printer.

top


Computer System & Architecture

 

When I launch DesignWorks, it prompts me for the registration. What should I do?

When you use Designworkd 5, you can find the "Register Codes.txt" file on "Start Menu\programs\Designworks Professional 5". Follow the instructions in the text file will fix this.

When you use Designworks 4, you can find the "Register Codes.txt" file on "Start Menu\programs\Designworks Professional 4". Follow the instructions in the text file will fix this.

top

I cannot open Logicworks project! What should I do?

The most common reason may be you are opening a project which was created under new version of Designworks:

The Logicworks 5 comes with the companion book is equivalent to Designworks 4.x

The project created under Designworks 5.x (installed on CSIL Windows computers) will not be opened under Designworks 4.x nor Logicworks 5.

top

I cannot use IOpanelDefault.html to debug my VHDL project! What should I do?

This is a known issue of the Designworks 5.x; the vendor has been informed and they are working on a solution.

In the meantime, please use Designworks 4.x for VHDL programming.

top

Designworks crashes when I launch it; sometimes Designworks behaves strangely, what should I do?

The Designworks crashes from time to time. This is a known issue. And there are cases it behaves out of ordinary.

Here is one workaround for this issue (warning: this will wipe out your customizations of Designworks):

  • launch Windows Explorer
  • goto the folder:
    \\freesia\userdata\username\AppData\Roaming\DesignWorks
  • delete this file: dwstate.ini

If this workaround does not work for you,

  • You may aoso give another try after a minute or so.
  • If this keeps happening, you may restart the workstation.
  • If you experience this on CSIL Terminal Server constantly, please email helpdesk; we will reboot the CSIL Terminal Server in 24 hours. In the mean time, please come to CSIL to use the workstations.

top


About PDF (Portable Document Format)

 

When I try to view a PDF file within a browser, I only got blank page. What should I do?

The most possible cause is the "Proteced Mode" of Adobe Reader. Please follow these steps:

  • launch Adobe Reader from start menu.
  • within the Adobe Reader, navigate through menu item: Edit -> Preferences...
  • in the newly opened Preferences dialog window, click "General" on left pane
  • on the right side, at the bottom, UN-check the "Enable Protected Mode at startup"
  • click OK to save settings, close Adobe Reader.
  • restart the browser, window will open and PDF content will show up.

A gental reminder: we have received many reports on issues related to in browser viewing of PDF; we strongly recommend viewing PDF outside of any browser.

top

When I try to view a PDF file with filled forms, I don't see the filled information. What should I do?

The most possible cause is: this specific PDF file is filled out by using the Mac Preview app instead of Mac Acrobat.

The symtoms: when the PDF is opend, it looks like it is not filled in. When click any input box, the filled data of this specific field shows up;  click another field will make the previous one disappear again. The printout of this document does not have filled info either. Basically, this file is totally useless.

The only thing you could do is: ask the person who created/saved/filled PDF file to re-fill the PDF file with proper application.

top

When I print a PDF file within a browser, the printout is not the same as on the screen! What should I do?

The short answer: Disable the in-browser viewing of PDF, period.

There are known issues of viewing PDF files in-browser. And there is no fix provided by any vendor yet.

The best way to viewing/printing PDF files is to us Adobe Reader (or Adobe Acrobat Pro if you have license) outside of browser.

Adobe does provide instructions on how to do this for multiple browsers; and you may want to check out this page for "modern web browsers".

Here is our summary of how to disable in-browser viewing PDF files (validated with Adobe Reader 17.011.30102 @ 2018.10.03):

For Mozilla Firefox (v62+):

  • It will not display PDF contents within the browsing window - it always saves/downloads it first. Good move!

(probably obsolete) For older versions of Mozilla Firefox (e.g. v31):

  • launch Firefox, click menu "Add-ons", click "Plugins" on the left side.
  • locate something like "Adobe Acrobat 11.x.x.xx"
  • change the action of this add-on to "Never Activate"
  • now, this specific add-on has greyed-out fonts and has "(disabled)" at the end of its name.
  • launch Firefox, click menu "Options", click tab "Applications"
  • under "Content Type" (left side), locate "Portable Document Format (PDF)"
  • for "Action" of this item, change it to "Use Adobe Reader (default)"
  • click button "OK" to save settings
  • close all Firefox windows and re-launch it to verify the correctness

For Google Chrome (v59+ Enterprise)

  • launch Google Chrome
  • click button "Customize and control Google Chrome" (aka the three vertical dots on the right side of the address bar)
  • click "Advanced" at the bottom of the newly opened "Settings" page
  • click "Content settings" within the section "Privacy and security
  • click "PDF documents" within the sub-section "Content settings"
  • turn ON "Download PDF files instead of automatically opening them in Chrome" on the new page for "PDF documents"
  • done!

(probably obsolete) For older versions of Google Chrome

  • launch Google Chrome
  • in the address bar, key in chrome://plugins and hit enter key
  • locate "Chrome PDF Viewer" and click Disable underneath it
  • now, when you left-click a PDF file, it will download it instead of previewing within the Chrome window
  • on the downloaded file notification tag (left-bottom corner of the Chrome windows), there is a small down arrow on its right side, click the arrow
  • click to enable the option "Always open files of this type"
  • done.

For Microsoft Edge:

  • At this moment, there is no way to disable Edge showing PDF contents within its browsing window. So, please always manually save it first and open it with Adobe Reader to ensure proper handling of PDF files.
  • Please contact Microsoft for more details.

(probably obsolete) for Internet Explorer (version 11 but before certain patches):

  • launch Internet Explorer, ensure you see menu bar, click menu "Tools -> Manage Add-ons"
  • under "Add-on Types", select "Toolbars And Extensions"
  • for "Show:", select "All Add-ons", wait for a few seconds
  • from the right pane, locate "Adobe Systems, Incorporated"
  • under this section, locate "Adobe PDF Reader", right click and select "Disable"
  • click button "close" to save the settings
  • close all Internet Explorer windows and re-launch it to verify the correctness

top


About Matlab

 

When I run Matlab, I don't see the Matlab window open. What should I do?

We some times got report about Matlab launching issues in CSIL. Please try the following workarounds before a solution is found.

You may want to reset the settings of Matlab by laucning:

Start Menu => All Programs => Matlab => reset_Matlab.bat

If you are logged on to a CSIL Windows workstation, the only shortcut to launch Matlab is:

"Matlab 2018b"

If this shortcut does not work, please try to launch Matlab on CSIL Terminal Server. And please report this to helpdesk (with your ID and the name of the problematic workstation.)

top

When I run Matlab, I cannot run certain Matlab fuctions. What should I do?

There are two known cases as following; you could try the fix/workaound in orderly fashion:

  • This may happen when you set the work directory on a location which Matlab has trouble with. (e.g. on a UNC path)

    Please close all running Matlab instances, and start the Matlab with the work directory on U:\

    (all the shortcuts to Matlab on the start menu have work directory on U:\)
  • This may be caused by the corrupted Matlab configuration set. Re-initialize the Matlab may solve the problem.

    Please close all running Matlab instances, and then run the following batch file:

Start Menu -> All Programs -> matlab -> reset_Matlab.bat

If the issue still persists after you tried the fixes for these two cases, please report to helpdesk asap.

top

When I launch Matlab, it shows some strange Java errors. What should I do?

The most likely cause is: the Matlab instance did not start in proper location.

Please ensure the shortcut for Matlab has "Start in" field has "U:\".

top

After I create and save a new function within Matlab, it says could not find it. What should I do?

We've seen many reports like this when the user functions are saved on the U: drive (SFU Home). The exact cause is still unknow and we are investigating.

The workaround: run "rehash path" to update function and file system caches.

Just a reminder: please keep saving files to U:, not anywhere else.

top


Miscellaneous

 

Mozilla Firefox won't start and claims that "Firefox is already running". What should I do?

Under Windows, Mozilla Firefox stores all configurations as part of user's profile (the Application Data to be precise). Since we are using roaming profile and folder redirection feature in CSIL, the Firefox may not work properly - it is not capable to handle concurrent use of Firefox under multiple logins.

We recommand to use either Google Chrome Enterpsise edition or Internet Explorer as they work better with the roaming profile with folder redirection feature.

If a web site is designed for Mozilla Firefox only, you may try the following workarounds:

WORKAROUND #1:

You may try to remove the "lock" file:

  • close all Firefox sessions, under all logins
  • launch Windows Explorer, within this Explorer window:
  • navigate to folder

\\freesia\userdata\username\AppData\Roaming\Mozilla\Firefox\Profiles

(Please put in your own username)

  • locate and browse into the profile folder, which has a random name
  • locate and delete the file parent.lock

Be warned: this workaround may not work for you; try the next workaround for better luck. And please email helpdesk about this.

WORKAROUND #2:

You may try to create a new profile for Firefox:

  • close all Firefox sessions, under all logins
  • locate the shortcut of Mozilla Firefox, make a copy to the desktop
  • right-click the new Firefox shortcut, select "Properties"
  • on the "Target" field, add "-P csil -no-remote" to the end of the line
  • click "OK" button to save the new shortcut
  • click the new shortcut to Firefox
  • follow the prompts, create a new profile, set it as the default.
  • next time, use this new shortcut to run Firefox

warning: this will remove all your Firefox configurations, e.g. bookmarks etc.


Extra notes:

For resolving the same issue on a Linux system, click here.

For more information from the vendor on this issue, click here.

top

When I browse a web site, a window popup saying "Application Blocked by Security Settings". What should I do?

This is a legit warning from the Java Run Time installed on the system.

WARNING: Please be extremely cautious while dealing with these sites; avoid them if you can. If you are not sure the legitimacy of the site, close the browse asap.

If you know the site you are visiting is legit, you could follow these steps to see the contents of this specific web page:

  • launch application "Configure Java"
  • click tab "Security"
  • click button "Edit Site List..."
  • click button "Add"
  • key in the URL of the site
  • click "OK" a few times to save the settings. You may have to acknowledge  the risk of adding http (instead of https) sites to continue.

Reload the page in question, and now you have the option to run the application within the "Security warning" dialog box.

top

When I use a CSIL Windows workstation, I notice many applications are missing. What's going on?

One thing for sure is: all the necessary applications for CMPT students are installed properly and they are in working order.

Here is a workaround if you encounter this situation: run the following command so you could find all the shortcuts you need for launching the applications:

explorer c:\programdata\microsoft\windows\startm~1\programs

Tech note: This is a bug of Windows 10 - the "Start Menu" sub-system keeps missing shortcuts. We are still searching for a solution.

top


More Info...

Is your question not on the list? Have you checked the CSIL Windows FAQ? If you have done that as well, please email helpdesk .

Last updated @ 2020.02.28